v5.4.9 Compatibility & Breaking Changes

When installing and upgrading to Morpheus v5.4.9, refer to the following to ensure compatibility.

Breaking Changes

  • 5.4.9: Morpheus 5.4.9 adds the “Provisioning: State” Role permission. This permission determines access to the State tab for Terraform-backed Instances and is set to “None” by default. On upgrade, only System Admin users will be able to see the State tab for these Instances. For other users who should have this access, edit their Roles to include “Provisioning: State” permissions.

  • 5.4.5: Warning: Database indexes added for account_usage and metadata_tag tables. Customers with very large account_usage and/or metadata_tag tables (10 million+) may experience slower initial morpheus-ui loading time after upgrading to 5.4.5, as well as additional database load.

  • 5.4.5: ‘AVI Load Balancer’ renamed to ‘NSX Advanced Load Balancer’

  • 5.4.5: Cloud Types disabled by default: Dell, HPE (NOT HPE Oneview), Supermicro and Cloud Foundry. Users would still be able to re-enable this clouds in the appliance settings. Does not affect existing Clouds.

  • 5.4.5: A10 Load Balancer type has been disabled, and will no longer be an option when adding new Load Balancers. Contact Morpheus if you need to re-enable A10 Load Balancer option. This does not affect existing Load Balancers.

  • 5.4.5: Morpheus Cluster type “Combo Cluster” renamed to “KVM/Docker Cluster”

  • 5.4.5: Greenfield managed vm’s (provisioned with Morpheus) can no longer be deleted in Morpheus without removing the actual vm/infrastructure. Restriction does not apply to brownfield vm’s that have been converted to managed.

  • 5.4.4: The Venafi and AppDynamics integrations are deprecated in v5.4.4 and will be removed in v5.4.5. AppDynamic will return as a plugin at a later date.

  • 5.4.4: The morpheus-ui logging configuration file has changed from logback.groovy to logback.xml in v5.4.4 (/opt/morpheus/conf/logback.xml). The logback.groovy file from previous versions can be removed, and any updates to logback.groovy will not result in any logging configuration changes.

  • 5.4.3: vCloud Director: Support for integrations with vCD 9 ended

  • 5.4.3: Morpheus Worker/Gateway v5.4.3 packages are now available. Existing Worker & Gateway nodes must be upgraded to v5.4.3 for compatibility with Morpheus v5.4.3 Appliances.

  • 5.4.2: vCloud Director: vCD 9.x will no longer be supported by Morpheus

  • 5.4.2: ServiceNow: Instance and Blueprint specific exposures will be removed from ServiceNow plugin support. More advanced configurations of Instances and Blueprints, in addition to Workflows, can be exposed utilizing Catalog Items

  • 5.4.2: After upgrading, it is recommended that you manually perform one “Daily” refresh Amazon Clouds to ensure availability of Amazon Service Plans for each region. To manually refresh a Cloud, navigate to Infrastructure > Clouds > (Selected Amazon Cloud) and select “Daily” from the REFRESH dropdown menu. If this is not done, Morpheus may not show Amazon Service Plans in the provisioning wizard until after Midnight UTC following the upgrade when the next automatic Daily sync would run.

  • 5.3.4: Major UI navigation structure changes. Refer to the Navigation Updates reference table

  • 5.3.3: Support for OpenStack v2 Identity API is removed

  • 5.3.2+: The local code repository path moved from /var/opt/morpheus/morpheus-ui/repo to /var/opt/morpheus/morpheus-local/repo to reduce potential shared storage issues and performance restrictions. The reconfigure process creates the folders and sets the paths in application.yml, no manual intervention is needed unless symlinks exisit on /var/opt/morpheus/morpheus-ui/repo/git which will need to be removed prior to reconfiguring - 5.3.2+ The deprecated /var/opt/morpheus/morpheus-ui/repo path will be automatically deleted in a future release but can be manually recursively deleted at any time for storage reclamation.

  • 5.3.2+: Provisioning ‣ Deployments has been moved to Provisioning ‣ Code ‣ Deployments

  • 5.2.9: OpenStack v2 Identity API is deprecated as of v5.2.9 (and is removed as of v5.3.3)

  • 5.2.6, 5.3.1: Appliance & Agent java version updated to 8u292-b10. jdk8u292 disables TLS 1.0 and 1.1 by default

  • 5.2.3+: codeready (codeready-builder-for-rhel-8-x86_64-rpms) repo access required for RHEL 8+ Appliances, replacing the previous PowerTools/powertools requirement

  • 5.2.1 & 4.2.5: API: Metadata: Metadata tags now referred to as tags and labels now referred to as labels. Previously metadata tags were referred to as metadata and labels were referred to as tags

  • 5.0.0+: When upgrading to 5.0.0+ from 4.x.x, any bearer tokens that have been generated are deleted which requires users to request new bearer tokens

  • 4.2.4: For appliances with externalized MySQL databases, due to MySQL deprecation of the “EDT” timezone you may need to update your database timezone to UTC or another compatible value. If this is not done, you will receive errors referencing timezone and Morpheus will not start. Morpheus should handle this change automatically for all-in-one appliances.

  • 4.2.1+: Tasks: Python: Virtual environment are now used for Python Tasks. Note: virtualenv is required on all Appliance App nodes

  • 4.2.1+: Puppet: Morpheus integration now supports version 6+. Puppet versions prior to 6 are no longer supported

  • 4.2.1+: Clouds: VirtualBox, VirtuSteam, and MetaCloud Cloud Types are no longer supported or available

  • 4.2.1+: Appliance: OS: Ubuntu 14.04 has reached its end of life (EOL) and is no longer supported as a Morpheus Appliance Host Operating System. Any Morpheus Appliance running on 14.04 must be upgraded to 16.04, 18.04, 20.04 or 22.04 BEFORE upgrading to 4.2.1+. Upgrades on 14.04 will not succeed

Morpheus Application OS

Morpheus can be installed on the following platforms. Please note the table below is for Morpheus Application OS support, not Morpheus Agent OS Support.

Note

If CentOS 8.2 is pinned to 8.2.2004 vault, the PowerTools repository will need to be pinned to 8.2.2004 to access freerdp-libs 2.0.0

Supported Appliance Operating Systems

OS

Version(s)

Notes

Amazon Linux

2

CentOS

7.x. 8.x (stream)

Debian

9,10,11

FreeRDP 2.0 is not compatible with Debian 9. Guacd will remain at 1.0.0 for Appliances running on 9.

RHEL

7.x. 8.x

Oracle Enterprise Linux (OEL)

7.x, 8.x

SUSE SLES

12, 15 replace:: 12, 15

Ubuntu

16.04, 18.04, 20.04, 22.04

14.04 is no longer supported for Appliance OS. Note: 14.04 is still supported by the Morpheus Agent.

Services

v5.4.9 Service Version Changes

Appliance
  • curl updated to 7.84.0

  • Elasticsearch updated to 7.17.5

  • erlang updated to v24.3, patch 24.3.4.2

  • Nginx updated to v1.22.0

  • Openssl updated to v1.1.1p

  • RabbitMQ updated to 3.9.20

  • Tomcat Updated to v9.0.64


v5.4.9 Service Versions & Compatibility

v5.4.9 Service Versions & Compatibility

Service

Compatible Branch

Morpheus Installer Version

Updated in v5.4.9

Plugin API

0.12.6

Morpheus Worker

5.4.8

MySQL

v5.7

v5.7.39

MySQL (FIPS)

v5.7

v5.7.39

Percona

5.7, WSREP 31

n/a

Elasticsearch

v7.x

v7.17.5

RabbitMQ

v3.5-3.9

v3.9.20

Tomcat

v9.0.65

Nginx

v1.22.1

OpenSSL

1.1.1p, 1.0.2u (FIPS)

Java

11.0.16+8

Java (macOS agent)

11.0.14+9


Morpheus Agent & Node Package Versions

v5.4.9 Agent & Node Package Versions

Package

Version

v5.4.9 Changes

Morpheus Node and VM Node Packages

3.2.9

No changes

Morpheus Linux Agent

v2.3.2

No changes

Morpheus Windows Agent

v1.8.0.0

No changes

Morpheus macOS Agent

v2.3.2

No changes


Security

Security Advisories

Advisory ID

Severity

Description

Updated On

MOR20220721-01

Critical ⬛️

Morpheus through 5.4.3 (which run Java 8) are confirmed to be impacted, Morpheus through 5.5.1-1 (for customers on 5.5.x Standard installations) and 5.4.8-2 (for customers on 5.4.x LTS installations) are potentially impacted if the vulnerability is found on Java 11.

07-21-2022

MOR20220524-01

High 🟥

An XXE issue was discovered in Morpheus through 5.2.16 and 5.4.x through 5.4.4. A successful attack requires a SAML identity provider to be configured.

06-08-2022

Plugin API Compatibility

v5.4.9 requires Plugin API version 0.12.6


Upgrade Paths & Methods

The following table shows supported version upgrade paths and methods.

From Version To Version
4.2.0 - 5.0.0 → 5.2.0 5.2.1 5.2.2 5.2.3 5.2.4 5.2.5 5.2.6 5.2.7 5.2.8 5.2.9 5.2.10 5.2.11 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.0 → 5.2.1 5.2.2 5.2.3 5.2.4 5.2.5 5.2.6 5.2.7 5.2.8 5.2.9 5.2.10 5.2.11 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.1 → 5.2.2 5.2.3 5.2.4 5.2.5 5.2.6 5.2.7 5.2.8 5.2.9 5.2.10 5.2.11 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.2 → 5.2.3 5.2.4 5.2.5 5.2.6 5.2.7 5.2.8 5.2.9 5.2.10 5.2.11 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.3 → 5.2.4 5.2.5 5.2.6 5.2.7 5.2.8 5.2.9 5.2.10 5.2.11 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.4 → 5.2.5 5.2.6 5.2.7 5.2.8 5.2.9 5.2.10 5.2.11 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.5 → 5.2.6 5.2.7 5.2.8 5.2.9 5.2.10 5.2.11 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.6 → 5.2.7 5.2.8 5.2.9 5.2.10 5.2.11 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.7 → 5.2.8 5.2.9 5.2.10 5.2.11 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.8 → 5.2.9 5.2.10 5.2.11 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.9 → 5.2.10 5.2.11 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.10 → 5.2.11 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.11 → 5.2.12 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.12 → 5.2.13 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.13 → 5.2.14 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.14 → 5.2.15 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.15 → 5.2.16 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.2.16 → 5.3.0 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.3.0 → 5.3.1 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.3.1 → 5.3.2 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.3.2 → 5.3.3 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.3.3 → 5.3.4 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.3.4 → 5.4.0 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.4.0 → 5.4.1 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.4.1 → 5.4.2 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.4.2 → 5.4.3 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.4.3 → 5.4.4 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.4.4 → 5.4.5 5.4.6 5.4.7 5.4.8 5.4.9
5.4.5 → 5.4.6 5.4.7 5.4.8 5.4.9
5.4.6 → 5.4.7 5.4.8 5.4.9
5.4.7 → 5.4.8 5.4.9
5.4.8 → 5.4.9
Rolling Upgrade Supported
Non-Rolling Upgrade Supported
Upgrade Not Recommended*
Upgrade Not Supported
Downgrade Not Supported

* Some Features and Fixes in the From version may not be included in the To version due to From version being released after the To version.

  • 4.2.0 to 5.0.0 Appliances require upgrade to 5.2.x or 5.3.x prior to upgrading to v5.4.9



Integrations

Note

Current iterations of Amazon AWS, Microsoft Azure, Google Cloud Platform, Digital Ocean, HPE OneView, OpenTelekom Cloud, IBM Bluemix, Softlayer and UpCloud are all supported.

Integration

Supported Version(s)

Notes

Ansible

2.7.x or higher

Ansible Tower

3.8.x

App Dynamics

4.5.x

Azure Stack

2002 back to 1908

2019-03-01-hybrid api-profile version used which is supported in 1908 and later Azure Stack versions

Cisco ACI

3.x,4.x,5.x

Citrix Netscaler

v12.1

Commvault

v11 sp 19

F5 Big-IP

11.4+

Infoblox

Latest Versions Supported

Jenkins

2.x

Kubernetes

1.x

Microsoft Hyper-V

2012R2, 2016, 2019

Nutanix AHV

5.0 - 5.10 Note: Prism Central is not a supported endpoint

In 5.5 - 5.7 if Prism Central is managing Prism Element, image creation will not function due to PC Image Management.

Openstack

Latest Versions Supported

When creating an OpenStack integration, select the latest available from the OS Version dropdown menu when running a later version

Puppet

6+

Puppet Agent version will be latest 6 version from yum.puppetlabs.com or apt.puppetlabs.com

Rubrik

4.2

SCVMM

2016, 2019

ServiceNow

Orlando, Paris, Quebec, Rome

Terraform

v0.11.x, v0.12.18+, 0.13.x, 0.14.x, 1.1.x

vCloud Director

10.0, 10.2, 10.3

When upgrading a vCD environment, you should update the API Version setting on the Morpheus Cloud configuration first

Veeam

10, 11

VMware ESXi

5.5, 6.0, 6.5, 6.7, 7

VMware Fusion

8, 9, 10+

VMware NSX

-V, -T (up to 3.1.3.x)

VMware vCenter

5.5, 6.0, 6.5, 6.7, 7

XenServer

7.x

Note

Non-listed versions may be compatible but are not verified.